crsctl start crs doesn’t start crs – 10gR2

Today morning a box got rebooted, crs(10.2.0.5 vesrsion) didn’t come up automatically. Manual crsctl start crs command didn’t update any log file in crsd,cssd, or even the alertxx4040.log

xx4040: (test1) /etc/oracle/scls_scr/test1/root> cat crsstart
enable
xx4040: (test1) /etc/oracle/scls_scr/test1/root>

So, as crsstart is enabled, it should have come up automatically.Ran cluvfy

xx4040: (test1) /home/oracle>cluvfy stage -pre crsinst -n test1,test2 -verbose

Performing pre-checks for cluster services setup

Checking node reachability...

Check: Node reachability from node "test1"
  Destination Node                      Reachable?
  ------------------------------------  ------------------------
  test1                                yes
  test2                                yes
Result: Node reachability check passed from node "test1".


Checking user equivalence...

Check: User equivalence for user "oracle"
  Node Name                             Comment
  ------------------------------------  ------------------------
  test2                                passed
  test1                                passed
Result: User equivalence check passed for user "oracle".

ERROR:
Path "/tmp/" is not a writable directory on nodes:
        test1,test2
Please choose a different work area using CV_DESTLOC.
Verification cannot proceed.

Pre-check for cluster services setup was unsuccessful on all the nodes.

/var/log/messages showed –

Oct 25 00:10:12 xx4040 logger: Cluster Ready Services waiting on dependencies. Diagnostics in /tmp/crsctl.5232.
Oct 25 00:10:12 xx4040 logger: Cluster Ready Services waiting on dependencies. Diagnostics in /tmp/crsctl.4628.
Oct 25 00:10:12 xx4040 logger: Cluster Ready Services waiting on dependencies. Diagnostics in /tmp/crsctl.5230.

Checked the ownership and permission on /tmp

drwxr-xr-x    14 root   root   4096 Oct 25 00:08 tmp

Changed the permission to 777 of tmp and started the crs, and all started well :).

Update from the comments by Frits Hoogland –> The required permission for tmp is 1777 where 1 is for the sticky bit.

While searching on internet, got another article which could be helpful –

http://blogs.oracle.com/gverma/entry/crsctl_start_crs_does_not_work

Advertisements

4 thoughts on “crsctl start crs doesn’t start crs – 10gR2

  1. When we DBA all over the world stuck with issues, Even when Oracle Support doesn’t help us out..It is Mr Anand who comes with a ray of Hope….Today you resolved my issue…I owe a debit of gratitude to you sir. thanks

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s